Silent Mayhem Clan Forums
 
HomeCalendarFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 Change to Required Java Version

View previous topic View next topic Go down 
AuthorMessage
Wicke Skillz
Admin
avatar

Posts : 39
Join date : 2011-11-02
Age : 27
Location : Brixham

PostSubject: Change to Required Java Version   Thu Nov 03, 2011 12:15 am

Some time ago, we announced that certain versions of Java will no longer be supported by RuneScape. From next week, this will come into effect and any players still using them will need to upgrade, or use our downloadable client.

The minimum version of Java required to run RuneScape will become 1.6, update 10.

We are making this change for a number of reasons:

Older versions of Java lack many features we would like to make use of to improve RuneScape – better graphics, sound and improved performance are areas we will be able to work on. You should immediately see improved performance if you update from older versions.
Older versions of Java have many serious security flaws. We encourage you to upgrade to avoid these.
It gives us many more options in the fight against bots.
We are at the stage where very, very few of our users will be impacted by the change. Right now, fewer than 0.3% of our players still need to upgrade.

If you are still seeing the warning when you load RuneScape saying your version of Java is out of date, you have two options:

Download and install the latest version of Java. This is a small, free, download available for all operating systems:
Microsoft Windows: Visit www.java.com and follow the free download link to get the version appropriate for your version of Windows. If you wish to choose your version manually, you can use http://java.com/en/download/manual.jsp instead.
Apple OSX 10.6 and above: Run your software update tool to update to the latest version of Java automatically.
Linux: Visit http://java.com/en/download/manual.jsp to download packages for commonly used distributions. Alternatively, use the normal software update mechanism built into your distribution to get the latest version of Java.
Download and install our own client. This is available here and works on Microsoft Windows and Mac OSX 10.6 and above.

As a result of the upgrade, the following operating systems will no longer be officially supported by RuneScape:

Microsoft Windows 95
Microsoft Windows 98
Microsoft Windows ME
Mac OSX 10.4
Mac OSX 10.5 32bit – If you have a 64bit version of OSX 10.5, please use our downloadable client.

Both of these version of OSX have been discontinued by Apple for a long time and unfortunately they no-longer provide new versions of Java for them.

At the same time, we will be removing the ‘unsigned’ method of loading the game. Unsigned mode gives poor performance for players and is a confusing fall back for when the game crashes or suffers compatibility problems. Additionally, it holds back our ability to provide better graphics, sound and game play for the vast majority of players using the normal game client (more than 99.5% of our player base).

The easiest way to tell if you are using unsigned mode is how you are presented with a list of worlds to choose from. If your world list is presented in-game in the lobby interface, you are using ‘signed’ RuneScape and nothing will change for you. However, if your world list is presented on the website (via http://www.runescape.com/slu.ws) then you are using unsigned mode. This web page will cease to exist after this update and you will have to switch to the signed version of the game. The easiest way to do this is to download and install our client here. If the downloadable client is not available in your region, then please follow the steps above to update to the latest version of Java.

If you have questions about or problems with the upgrade, please visit the technical support forum, or contact our Player Support team directly.
Back to top Go down
View user profile http://silentmayhem.forumfree.co.uk
 
Change to Required Java Version
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» How to change the colour of the eyes with photoshop (red,blue...anything)
» Did mother's day change?
» Click the Ball......Change its Color
» Things Change Daily
» Changes for Version 2

Permissions in this forum:You cannot reply to topics in this forum
Silent Mayhem :: Announcements :: Game Updates-
Jump to: